№ 4770 (Уровень: Сложный)
На числовой прямой даны два отрезка: P=[35,55] и Q=[45,65]. Определите наименьшую возможную длину 
отрезка A, при котором формулы

(x ∈ P) → (x ∈ А)

(x ∉ A) → (x ∉ Q)

тождественно истинны, то есть принимают значение 1 при любом значении переменной х.


def f(x):
    P = 35<=x<=55
    Q = 45<=x<=65
    A = False
    
    return (P<=A) and (not A<=(not Q))

a = list()
for x in range(35,66):
    if f(x)==False:
        a.append(x)
print(a)
